Gemeni 2.5 pro 503 errors

Hi There!

I am running a SaaS with 150 law firms on it and Gemeni in critical workflows, We are seeing a huge surge in 503’s we have retries and backoff but still a high failure rate? Is anything being done to address this?

A month ago we were having a similar issue with Gemini 3.1 Flash-Lite
In our case, we solved it by deleting the IP at the end of the url we were using in the API call to the model. I’m not sure about the details, but it seemed to be like we were sending the requests to an only model instance, or that pinpointing that IP was avoiding that our requests could be redirected to other IPs.

Hello @Mitchell_Francis ,

503 errors are due to our services being temporarily overloaded. Please see this pinned post for suggestions on how to handle this.

Yes but this this is a weeks worth of it? I don’t understand how a paid API is this unreliable? We have implemented retries with backoffs etc…But is there any timeline on how long the API is going to be this bad for?

Chiming in here as we are experiencing the same with 3.6 and 3.7 Flash. I agree it shouldn’t be this unreliable. Almost feel like our paid API requests are being routed through a free API.